Scheduled for July 24, 2026 at 11:00 AM – 11:15 AMUTC
Affects
Splitwise Pay
Under maintenance from 11:00 AM to 11:15 AM
Updates
Completed
July 24, 2026 at 11:15 AMUTC
Completed
July 24, 2026 at 11:15 AMUTC
Maintenance has completed successfully.
In progress
July 24, 2026 at 11:00 AMUTC
In progress
July 24, 2026 at 11:00 AMUTC
Maintenance is now in progress
Planned
July 23, 2026 at 8:06 PMUTC
Planned
July 23, 2026 at 8:06 PMUTC
We're planning a brief maintenance window for Splitwise Pay, our in-app payment feature (US only). Payment services and the Splitwise debit card will be temporarily unavailable. Please wait until the window has ended to complete your transactions.